Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-18-2002, 01:17 PM
TSL TSL is offline
Registered User
Join Date: Jul 2001
Posts: 81
Tach help

I have installed a Pertronix system to replace points, this worked good with no problems, except:
1972 - 107
116.982 engine

After installing tach has gone crazy. At idle it shows 2000 rpm and jumps up very quickly to 7000 when apply gas.
They(Pertronix) recommended this:
2 - inline 3 amp, 400V rectifiers, did this and no tach responce
1 - inline 3 amp, 400V and tach idle correctly but, apply gas and jumps very very quickly to 7000

Tach did work before.
Seeking to replace tack but none seem available.
Please help, do not want to go to a aftermarket.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:41 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page