Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-07-2002, 02:35 PM
Registered User
Join Date: Jan 2002
Location: Colorado Springs, CO
Posts: 1,006
Hi all,

I changed the front struts and rear shocks using dealer shocks. The ride seems a bit more firm. The car is also 1/2" lower all around, I don't know if this is normal or not. The front now vibrates some at speeds > 60 but below that it seems like the ride is nicer than before. I can't help but wonder if some wierd alignment situaiton is causing the vibration, much as I'd like to think its balance, I don't see how balance changed in my garage.

It still seems to bang pretty hard when going over a bump in the road. Any ideas?

I'm changing the subframe bushings while I'm at it. They're original and while not torn, rubber does age so I'm doing it now to save on repeated alignments. I may change the springs too, that way I'll have a new suspension front and rear, the oldest parts being the tie rods, 13 months old, second oldest rear suspension links, 10 months old.

Its a lot cheaper and more rewarding to do the work myself.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:27 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page