Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-21-2002, 07:42 PM
Posts: n/a
Alarm problem

I have a 1993 500e that is having alarm problems. When I unlock the driver's side door, the central locking system works properly and unlocks all the doors, but the alarm doesn't disarm. When I open any door, the alarm goes off. I can get it to go off by going over to the passenger side and locking and unlocking.

Any ideas of where to look?


Reply With Quote
Old 09-21-2002, 08:25 PM
jbaj007's Avatar
Registered User
Join Date: Jun 2001
Location: Santa Monica, CA
Posts: 2,053
Assuming orig. factory alarm. There is a microswitch associated with ea. front door lock cylinder (and trunk). This arms/disarms the alarm. These are not available as a separate piece when I checked last and the whole deal has to be replaced if bad. They are suspect due to weather intrusion. There is a plug to the pigtails on this switch (gn.,yl.,br/bk wires last I saw one) that cracks at the wires insertion point and this can sometimes be repaired with a steady soldering hand.

The central locking system uses a separate swich on the actuator itself so this doesn't help the alarm any.

My bet is on a cracked green wire at the micoswitch plug.
The Golden Rule

1984 300SD (bought new, sold it in 1988, bought it back 13 yrs. later)
Reply With Quote
Old 09-22-2002, 07:05 AM
Posts: n/a
Thanks for the info, I'll give it a try.

Reply With Quote
Old 10-10-2002, 04:35 PM
Registered User
Join Date: May 1999
Location: Charlotte, NC, USA
Posts: 688
Answer to the problem?

My '93 400E has exactly the same symptoms as your 500E and was wondering if you found the answer to the problem. I suspect the passenger door assembly but not sure yet. Another quirk it also does is LOWERS the windows when locking and RAISES them when unlocking. It appears to be out of phase somewhere or like the 'battery terminals reversed' which I know it can't be!
Thanks for your insight.

Tobias MB
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:22 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page