Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-07-1999, 05:25 PM
Greg
Guest
 
Posts: n/a
Concerning the "erratic running" post below, would a bad EGR valve cause this problem? This didn't occur until I disconnected the EGR for vacuum reasons. The Haynes manual says this surging is caused by a faulty fuel pump: how can I check this? could it just be bad fuel filters (or something equally simply and inexpensive)? I don't want to jump to conclusions and start replacing components needlessly. Thanks
  #2  
Old 07-07-1999, 11:01 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
What kind of car. Why don't you register and put your car in your signature.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #3  
Old 07-08-1999, 10:53 AM
Greg
Guest
 
Posts: n/a
'83 300D
  #4  
Old 07-08-1999, 09:58 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Start with the filers. Then when you have off the pre-filter, take off the fuel fill cap and blow air into the line that goes into the pre-filter. It will blow out any excess dirt or algae on the screen in the tank. The other thing that can cause this is the tank check valve. It is under the car and is grey in color.

We sell all of these parts on the partshop.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1998 C280 Temperature running higher. Ionman Tech Help 12 04-05-2011 02:02 PM
'02 ML 320 Running Board Illumination & Interior Lights jgl1 ML, GL, G-Wagen, R-Class, Unimog, Sprinter 1 02-06-2004 06:25 PM
running cool in the mountains (cold temps outside) stejm Vintage Mercedes 11 01-08-2004 12:25 AM
Running Hotter Than Normal chrisalex78 Diesel Discussion 19 11-04-2003 11:26 PM
1987 190E 2.6 Running Rich?? arnelrac Performance Paddock 3 02-27-2002 02:17 PM



All times are GMT -4. The time now is 09:56 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page