Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 11-08-2002, 03:59 AM
Christian
Guest
 
Posts: n/a
Id go with the simple things first. Change the oil filter and oil, spark plugs. If it still seems the same it may be something bigger. My dads car sounds exactly like yours. Its even a 1989 300TE. It used to start out in 2nd gear cold very well. Then when it was warm, it still starts in second but feels like it wont move. The sluggishness came from an engine that needed a complete overhaul. Simple as that really

Christian

1989 300TE
1994 E280
Reply With Quote
  #17  
Old 01-07-2003, 11:39 AM
Member
 
Join Date: Jul 2002
Location: Carson City Nevada
Posts: 59
Thanks for advice guys. Here's what I've done since last update. I replaced both fuel pumps and it appears it fixed the sluggish problem 90% of the time. One of the fuel pumps was pretty noisey. Anyone have suggestions for getting rid of the sluggishness 100%?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page