Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-01-2002, 07:02 PM
Registered User
Join Date: Aug 2002
Location: Dallas, TX
Posts: 5
C230 Accelerator pedal pressure

I have noticed that the accelerator pressure on my C230 Kompressor is really high, something that gets really irritating while driving for a while. I am wondering if other drivers have this same issue, and is there a way to make it a lil more weaker.
Reply With Quote
Old 10-01-2002, 09:08 PM
haasman's Avatar
Registered User
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,096
It could be that your the throtlle cable/linkage, from the pedal to the engine is simply dry and is in need of lubrication.

Also, be sure and check under the gas pedal, although obvious, it could be that debris has accumulated underneath.
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
Old 10-02-2002, 03:06 AM
David C Klasse's Avatar
CheFrac is Back!
Join Date: Jan 2001
Location: Mission Hills in the City of San Diego
Posts: 2,352

This car's accelerator is very light;.... and requires very little pressure to push it.... All of the newer Mercedes' lost the cable to the engine all together... it barely passes the firewall.

This is just the inherent design of the pedal... you'll have to live with it.....

2006 E350 w/ 155k miles (Daily Driver)

1993 300E 3.2L Sedan w/ close to about 300k miles
2003 E500 Brilliant Silver (Had 217k miles when totalled!)
1989 300E with 289,000 miles (had for <1 yr while in HI)
03 CLK 500 cabrio (Mom's)
2006 C230k (Dad's)
1999 S420 (Mom's/Dad's)
2000 C230k Sport sedans
2001 CLK320 Cabrio (Mom's)
1995 C280 My First Mercedes-Benz... (155k miles. EXCEPTIONAL AUTOMOBILE. Was Very hard to let go of!)
Reply With Quote
Old 10-02-2002, 09:20 AM
blackmercedes's Avatar
Just a guy
Join Date: Dec 2000
Location: St. Albert, Alberta, Canada
Posts: 3,492
I don't find my 1998 C230's pedal pressure uncomfortable, but I have been driving MB's for some years, and may be used to the longer travel and higher pressure.

A 1999 car might still have warranty coverage, and you could ask the dealer to examine it. A better bet is to find another C230K (99 or 00) and compare it to yours. Maybe look for one for sale.

The car uses a drive-by-wire system that has the throttle cable ending at the second firewall, connecting to the engine via electronics. There is a spring return system at the final point of the cable, and it is quite accessible at the drivers side near the fusebox. You should have a look and see if something is binding, but I would be wary of applying any type of lubricant, as there are lots of electronic components in this area...
John Shellenberg
1998 C230 "Black Betty" 240K

Reply With Quote
Old 10-02-2002, 12:09 PM
Posts: n/a
The accelerator pressure on my wifes 00 C230 is very light. I would check the pedal to make sure the bottom hinges are not binding and at the firewall where the cable attaches to the sending unit (throttle by wire) to see if maybe it is binding there or is dry.

Nice technology, works great on aircraft!!

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:54 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page