Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 07-12-1999, 08:29 PM
Jim Collins
Posts: n/a
About a month ago, my car wouldn't start and I replace the relay for the fuel pump. Seemed to fix it until last weekend, when the car wouldn't start while on vacation in Indiana. finally got it started after using starting fulid and a jump for about an hour. Got it home and it died. Rotor and Dist. cap seem to be worn, but plugs still fire. I pour a little gas into the intake but the engine does'nt hit a lick. Fire to the plugs, gas in the engine, but nothing...engine was running when I shut it off so I don't think the timing slipped. Havn't checked compression but it seems ok. Any ideas? Please help!


Old 07-12-1999, 09:04 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I would start with replacing the cap and rotor if they are not new. The plugs might fire while out of the engine, but once under pressure, the fire will go to the path of least resistance. I had a shop tow me a car with this exact problem and the cap was the problem. Could also be the coil.


Old 07-15-1999, 10:09 PM
Jim Collins
Posts: n/a
Replaced cap & rotor, no help but it needed it anyway. Replaced coil and that fixed it!
Thanks for your help.
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1987 420 sel no start benzboy Tech Help 4 01-13-2005 10:40 AM
1988 420 sel no start JCAUTOWRKS Tech Help 7 10-28-2004 07:29 PM
87 420 sel missing badly after warmup denismitchell Tech Help 14 04-01-2004 01:29 AM
Starting problems '87- 420 SEL Berolina Tech Help 11 06-10-2003 05:35 PM
W126 420 SEL Dome light diagnosis help... 96C220 Tech Help 14 11-07-2002 01:11 AM

All times are GMT -4. The time now is 01:28 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page