Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-12-2002, 05:02 AM
Oliverp's Avatar
Registered User
 
Join Date: Aug 2000
Location: Toronto, Canada
Posts: 436
questions on a car I've seen

Hi everyone

I'm looking at a 1988 420SEL today. The car is cheap and comes with no history, but it seems to be mechanically sound (unless the man selling it is a complete B*****d!!).

The onlly problems it has is the passenger side window doesn't want to work (I'm not too worried about that just yet). The problem I was a little concerned about is that none of the lights on the dash or console work. Could this be something major, or is it most likely a DIY job?

Thanks in advance everyone
__________________
Oliver Plante

---My Previous MBs---
87 300SE (Sold) - Black, Cream Leather
89 300SE (Sold and missed) - Black, Cream Leather
87 420SEL (Died!) - Bronze, Black Leather

---Father's Previous MB's---
2004 S320 CDi - Black, Cream Leather, 18" AMGs
2001 CL500 (Stolen!) - Black, Cream Leather
1999 E55 AMG - Black, Black Leather
1994 500SE - Black, Cream Leather
1990 300SE - Midnight Blue, Cream Leather
1986 420SEL - Diamond Blue, Cream Leather
Reply With Quote
  #2  
Old 10-12-2002, 12:06 PM
Registered User
 
Join Date: Jan 2002
Location: England
Posts: 1,841
Are you buying it privately or through an independant dealer?

None of the problems you mentioned are serious, and could be fixed fairly easily by you if you have the time.

As I'm sure you're aware, be wary of a Mercedes with no history. Especially a cheap one..

Generally you'd expect a 420 S-class Long wheelbase to be well maintained and looked after, including at the least some service history, so make sure you convince yourself there's a genuine reason for lack of history (and there's plenty of them).
If you wanna be really picky and sure about the car, I would check things like:
Does the AC still blow cold, do the tyres match, are first aid kit & triangle in place? Might give some indication as to its past, and its recent maintenance/lack of. And of course mileage could easily read 100k but be more like 250k.

But I'm guessing you know all this and more already, so with all that said, a cheap W126 should still be solid and run for many more miles if you're prepared to sacrifice a little money and/or time.

good luck!
__________________
190E's:
2.5-16v 1990 90,000m Astral Silver
2.0E 8v 1986 107,000m Black 2nd owner
http://www.maylane.demon.co.uk/190esmall.jpghttp://www.maylane.demon.co.uk/190esmall2.jpg
Reply With Quote
  #3  
Old 10-12-2002, 12:41 PM
Bear's Avatar
Registered User
 
Join Date: Jan 2002
Location: London,England
Posts: 495
Oliver try hitting the dash with the flat of your hand to see if the light's work,bit crude but it should work.Later Bear
__________________
W123 '82 300D red 202,000 miles

G460 '83 280 GE LWB 69,000 miles

Mercedes-Benz Club member
http://www.mercedes-benz-club.co.uk/

S Klasse Club Deutschland
http://www.s-klasse-club.de/
Reply With Quote
  #4  
Old 10-13-2002, 03:28 AM
Oliverp's Avatar
Registered User
 
Join Date: Aug 2000
Location: Toronto, Canada
Posts: 436
Thanks for the replys. I've bought the car!

Firstly, the good stuff: Engine seems very smooth, and gearchange is also ultra smooth. The leather, and most of the interior is almost perfect. Air-con works!

Now onto the other bits:

None of the dash or console lights work, although all of the warning lights are OK.

When engaging either drive or reverse, sometimes it really does clunk a bit, although as I said above, actual gear change while driving is silk. Is this going to be a gearbox problem or something like a mount problem?

The oil light is on, although I have checked the oil a number of times and it is just below maximum. Could this be the sending unit or something?

Under some acceleration, it does blow out a bit of smoke, but I think the car has been standing for a good while, so I'm going to change all filters, oil and plugs today.

Paintwork isn't perfect, and there are a couple of broken pieces of interior trim that I need to replace, but for 1000 I think I got a pretty good deal.

It's my first V8 Mercedes, and I really do enjoy it!!

I'll send in some pics soon.

Thanks for all the input again
__________________
Oliver Plante

---My Previous MBs---
87 300SE (Sold) - Black, Cream Leather
89 300SE (Sold and missed) - Black, Cream Leather
87 420SEL (Died!) - Bronze, Black Leather

---Father's Previous MB's---
2004 S320 CDi - Black, Cream Leather, 18" AMGs
2001 CL500 (Stolen!) - Black, Cream Leather
1999 E55 AMG - Black, Black Leather
1994 500SE - Black, Cream Leather
1990 300SE - Midnight Blue, Cream Leather
1986 420SEL - Diamond Blue, Cream Leather
Reply With Quote
  #5  
Old 10-13-2002, 09:05 AM
Registered User
 
Join Date: Jan 2002
Location: England
Posts: 1,841
Quote:
Originally posted by Oliverp

It's my first V8 Mercedes, and I really do enjoy it!!
You must have the ultra-rare E55 straight-six cylinder then
I guess you don't own the E55..

Can't complain at that price - hope it works out well!
__________________
190E's:
2.5-16v 1990 90,000m Astral Silver
2.0E 8v 1986 107,000m Black 2nd owner
http://www.maylane.demon.co.uk/190esmall.jpghttp://www.maylane.demon.co.uk/190esmall2.jpg
Reply With Quote
  #6  
Old 10-13-2002, 01:50 PM
Oliverp's Avatar
Registered User
 
Join Date: Aug 2000
Location: Toronto, Canada
Posts: 436
Yup! Belongs to my pops.

One day he'll let me drive it..................... one day........

Maybe.....

__________________
Oliver Plante

---My Previous MBs---
87 300SE (Sold) - Black, Cream Leather
89 300SE (Sold and missed) - Black, Cream Leather
87 420SEL (Died!) - Bronze, Black Leather

---Father's Previous MB's---
2004 S320 CDi - Black, Cream Leather, 18" AMGs
2001 CL500 (Stolen!) - Black, Cream Leather
1999 E55 AMG - Black, Black Leather
1994 500SE - Black, Cream Leather
1990 300SE - Midnight Blue, Cream Leather
1986 420SEL - Diamond Blue, Cream Leather
Reply With Quote
  #7  
Old 10-14-2002, 03:39 AM
Oliverp's Avatar
Registered User
 
Join Date: Aug 2000
Location: Toronto, Canada
Posts: 436
I'll give that a go, but to be honest, I think it's something else. Even the lights on the window switches in the rear doors don't work.

I'm taking it to an auto electrical store today to see what they can do.

I'll be taking pics today, and most likely posting them with loads of questions!

My oil light has gone out now, I'm pretty sure the car has been standing for a long while, and I think it's starting to smooth out now. All filters and fluids will be changed today.

Thanks for all your comments, it makes me feel a lot 'safer' after buying this car!

All the best,
__________________
Oliver Plante

---My Previous MBs---
87 300SE (Sold) - Black, Cream Leather
89 300SE (Sold and missed) - Black, Cream Leather
87 420SEL (Died!) - Bronze, Black Leather

---Father's Previous MB's---
2004 S320 CDi - Black, Cream Leather, 18" AMGs
2001 CL500 (Stolen!) - Black, Cream Leather
1999 E55 AMG - Black, Black Leather
1994 500SE - Black, Cream Leather
1990 300SE - Midnight Blue, Cream Leather
1986 420SEL - Diamond Blue, Cream Leather
Reply With Quote
  #8  
Old 10-14-2002, 09:44 AM
Registered User
 
Join Date: Jan 2002
Location: England
Posts: 1,841
I believe the lights in the rear door window switches don't come on if the 'lock' switch is switched on.. worth a check.

If the car has been standing, I would definitely consider changing the oil, then changing it again after a short distance (not sure how far.. 100 miles?) if you want the engine to be 'cleaned' effectively.

Also, be sure to change the oil while hot.

later!
__________________
190E's:
2.5-16v 1990 90,000m Astral Silver
2.0E 8v 1986 107,000m Black 2nd owner
http://www.maylane.demon.co.uk/190esmall.jpghttp://www.maylane.demon.co.uk/190esmall2.jpg
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page