Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 07-26-1999, 09:16 PM
Registered User
Join Date: Jul 1999
Location: malvern, pa usa
Posts: 63
Recently purchased a well maintained, 150K, '87 300D. Drove back from TX to PA and car ran great. Over next few weeks, started running poorly, slow acceleration, poor fuel milage.
Tried all the fixes that work on the '83, but little improvement. New calibrated injectors, fuel filters, air filter, cleaned vacuum control lines, checked switchover valves, pulled and desludged intake manifold and air pipe, cleaned over pressure sensor, disabled EGR, and ran Diesel Purge through system. Some days runs better than others, but always has a noticable lag in acceleration at approx. 2000rpm under full throttle. Any suggestions?


Old 07-26-1999, 09:25 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Has the Trap oxydizer mod been done? Emission recall. Has the timing chain been checked for stretch?
Old 07-26-1999, 09:53 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Many had the problem with the timing chain. These cars usually are really fast. Have the vacuum/boost line checked that goes from the intake to the sensor in front of the battery. I have seen many bad. Also check the wastegate hose.


Old 08-01-1999, 02:19 AM
Registered User
Join Date: Jul 1999
Location: malvern, pa usa
Posts: 63
The TO has been replaced. Will check chain and additional vacuum lines. Vacuum looks like the problem as trans shifting is now becoming erratic.

Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
We often overlook Fuel Pump damage--Low Sulfur Fuels and bad fuel (85 300D) Carrameow Diesel Discussion 16 11-15-2007 05:43 AM
Opinions on purchasing a 1987 300D swogee Diesel Discussion 12 05-03-2005 10:27 AM
1976 W115 300D motor into 1979 W123 300D sebtowne114 Diesel Discussion 5 04-14-2005 07:26 AM
auto tranmission problem in 1981 300d o2pilot Diesel Discussion 2 06-15-2004 11:19 AM
300D turbo slushbox vs 300D n/a 4 speed The Warden Diesel Discussion 5 05-28-2004 12:40 AM

All times are GMT -4. The time now is 12:02 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page