Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-28-1999, 09:55 AM
whg
Guest
 
Posts: n/a
Now that the oxygen sensor in my 89 300TE has been replaced, upon being started, the engine winds up to about 1500 rpm then drops back sharply to about 500 rpm, frequently stalling. Sometimes, while the engine threatens to stall, the ABS light stays on, even when driving off. Eventually, the ABS light turns off. Once the car has reached operating temperature, it runs well and starts without stalling -- but it still winds up then drops. Before the O2 sensor was replaced, the engine occasionally threatened to stall while idling with the ABS light on, but it did not wind up on starting.

** more details **
I wanted to add that the rpm jumps to about 1500 upon ignition, in what seems a normal fashion, falls in what seems a normal way to about 600, then climbs to 1500 over about half a second. Only then does it drop to stall. It is as though the computer is looking for a signal while it raises the rpm and then giving up.

Any hints?

Many thanks.

Willy Gilson

[This message has been edited by whg (edited 07-29-1999).]
  #2  
Old 07-28-1999, 07:08 PM
rego
Guest
 
Posts: n/a
Willy

Have you tried the temperature sending unit on the rear of the cylinder head. It controls the cold start. I broke mine accidently and before I replace it with a new one my car did about the same thing. Once it started warming up it ran fine.

Larry
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
123 = Economy, 124 = Expensive LarryBible Diesel Discussion 220 02-26-2006 09:30 PM
FS: H&R lowering springs 124 schumi Mercedes Used Parts For Sale & Wanted 1 10-14-2004 04:11 PM
1991 300e VS. 2001 C320 Evan Featured Cars 24 09-28-2004 09:14 PM
'89 190E stalls intermittenly KSeed Tech Help 10 09-17-2003 01:13 PM
Pontiac V6 stalls on cold startup The Warden Off-Topic Discussion 2 04-07-2003 01:35 PM



All times are GMT -4. The time now is 12:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page