Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-21-2002, 01:57 AM
Posts: n/a
Exclamation 450slc no start diaginosis

i have a 1974 450 slc mercedes 4.5 v8 . it was runny with a slight idle problem but other then that i couldnt ask for much more out it. I drove it for about ten minuetes and then i let the car sit for proably an hour while i did a few other things. i went back out to start the car.
the car would turn over as if it where going to start. but it doesn't. the car will make a sounds like it almost ready but it doesnt have enough fuel to get it really going.
Ive tested the spark on one of the plugs. i checked the voltage at the fuel pump which is about 6.4 i think. If i spray carberatuor cleaner into the air intake and it almost fired if i heald the gas pedal all the way down. That worked till it started flaming backwards out of the air intake.(my freind burned his knuckle hair off). so thats where i stopped i think ill do a compression test on the engine and check all the spark plugs for sparks. then ill check the fuel pressure throught out the system. I am a beginger mechanic so i have acces to a lot of tools.

Last edited by will81185; 10-21-2002 at 02:09 AM.
Reply With Quote
Old 10-23-2002, 09:11 PM
Registered User
Join Date: Aug 2001
Location: Evansville, Indiana
Posts: 8,150
Pull the right valve cover and see if the timing chain is still there. If so, set engine to TDC on #1 and see what the valve timing is. If it fires up the intake, make sure the rotor isn't broken.

Also, check for a clicking sound from the injectors, and make sure the fuel pump is running.

6.4 volts isn't enough at the fuel pump, it requires 9. Should run for a second or so when you switch the ignition on, and then while cranking.

You can also check by pulling the relay in the box under the passenger side kick panel -- top one on the front set. Bridge the terminals labled 30 and 87, key on. Pump should run. If it doesn't, and you don't have good voltage, pull the next relay down and bridge it the same way. If pump runs, replace second relay.

If the pump does run, replace the first relay.

1972 220D ?? miles
1988 300E 200,012
1987 300D Turbo killed 9/25/07, 275,000 miles
1985 Volvo 740 GLE Turobodiesel 218,000
1972 280 SE 4.5 165, 000 - It runs!
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:24 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page