Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-29-1999, 11:37 PM
Jim
Guest
 
Posts: n/a
Just bought a 1990 190 2.6. The car has been sitting for a year, has 90K and a rebuilt transmission - two years ago (not MB). When starting in the morning it will shift thru the gears until it reaches 4th then nothing. It's as if it goes into neutral. If I manually shift back to third it goes in gear. When I drive it in third for a few minutes and then shift to forth it goes into gear. It is perfect for the rest of the day, never slips and shifts like a new transmission. Had the filter and fluid changed by MB, perfect, no debris in the fluid. MB wants to install a new trany(2,700.00) Someone suggested that I adjust the shift cable, make it shorter.Any suggestions?
  #2  
Old 07-30-1999, 10:45 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Sounds as if you have a valve body problem. But who knows. The best bet is a reman Merc trans.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
1999 S500 with 722.6 Automatic Transmission Filled for life? MBD Tech Help 29 07-30-2011 12:51 PM
190 2.5D transmission noise ? LINDS HANSON Tech Help 3 10-27-2007 10:07 PM
190 E 2.6 transmission questions (long) David Rose Tech Help 3 08-09-2005 12:09 AM
M116 removal from 82 380SL rstarkie Tech Help 3 11-14-2002 08:03 AM
190 D 2.2 - Transmission Upshift Problem jgl1 Tech Help 1 02-07-2001 10:08 PM



All times are GMT -4. The time now is 04:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page