Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 10-30-2002, 08:29 PM
Registered User
Join Date: Aug 2001
Posts: 32
fuel pump relay location

I have a new fuel pump relay for a 91 300SEL. I can not find its location in my car. I have been told its in my fuse box, I assure it is not. I was told at my shop that its between my two firewalls next to my MAS relay or OVP, but I can not find it. I have read in this form that it maybe part of the MAS relay but found nothing conclusive.

I have attached a picture. Not too many 300SEL's in this board in appears but if anyone can help I would be greatful.
Attached Thumbnails
fuel pump relay location-300sel_1.jpg  
Reply With Quote
Old 10-30-2002, 10:08 PM
Registered User
Join Date: Aug 2001
Posts: 32
Figured it out!!!!!

I have a 90 300E and a 91 300SEL. I took out the MAS relay from the 300E and plugged it into the 300SEL. FUEL PUMP works on the SEL! I found one post that talks about MAS units containing the fuel pump relay.

Do the M103 motors have the fuel pump relay included in the MAS relay? Neither of my cars have a fuel pump relay.

Why does FAST LANE show a fuel pump relay for both the 300E and 300SEL when it appear that they do not have one? Nothing against FAST LANE, my local benz shop thought the car had a fueld pump relay too.

This post is for the benefit of the next poor fellow who is trying to figure this one out. The parts books appear to not be very clear on this subject.
Reply With Quote
Old 10-30-2002, 10:23 PM
Join Date: Jan 2002
Location: Lynchburg, VA
Posts: 52
You may have looked at my post about the fuel pump relay being inside the MAS. I too was looking all over for the fuel pump relay on my 190e 2.6. It wasn't till I saw in performance products catalog that it stated that the MAS contained the Fuel pump relay and the AC compressor relay. I don't know, unless you can take the MAS apart and change out the relay inside.

Was your sel not starting? What were your symptoms?
90 190 E 2.6 162K
91 300 E 117K
90 Laser RS turbo 169K
"The one who dies with the most toys wins"
Reply With Quote
Old 10-30-2002, 10:46 PM
Registered User
Join Date: Aug 2001
Posts: 32
This is really a continuation of a tread I posted last weekend when I was asking if I fried my fuel pump relay or fuel pump because I was an idiot. The 300SEL would not start because I hit the fuel pump electronic connectors. I knew my problem and wanted to try the easy fix first, the relay.

I searched as best I could about the relay and thought that I would have found more on the combination MAS and fuel pump situation. If I would have found this out I would have swaped the MAS to see if the problem was under the hood and not the pump. I knew that the MAS unit was the same for both cars.

SIDE BAR: As it turns out I have an extra MAS from my 300E because I thought that the MAS relay in the 300E was causing my AC to not work. As it turns out that was not the problem so I am going to plug that MAS relay into the 300SEL, forget the $70 core charge on the new MAS I bought recently and probably be on my way. I did not return the MAS figuring sorry no return on electronic parts. I will wait till next summer to figure out the AC situation in the 300E...cause its getting cold in Kansas City.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:08 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page