Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-01-2002, 07:23 PM
rdanz's Avatar
Registered User
 
Join Date: Sep 2002
Posts: 1,158
Brake ?

94 S350
Sometimes for no apparent reason I feel grinding when I apply my brakes at low speed as it does this once in awhile I'm begining to become concerned if there is a problem. Pads seem to be in good shape. What could this be?
Reply With Quote
  #2  
Old 11-01-2002, 07:43 PM
Registered User
 
Join Date: Jul 2002
Location: Dallas
Posts: 330
Probably a little rust on the rotors? Is this usually after there has been rain or the car has been sitting up for a while after washing? I think this is normal.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page