Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-03-2002, 08:57 AM
Registered User
Join Date: Nov 2002
Posts: 11
abs chatter

I have an intermittent problem on my '87 560sel. Sometimes, when applying brakes, I get a subtle grinding sound and stopping distance seems to increase. Most of the time brakes work well and car stops on a dime. Problem seems to be more apparent when there is moisture...such as after washing car, or when it is raining. Any help? Thanks
Reply With Quote
Old 11-03-2002, 09:53 AM
Registered User
Join Date: Jun 2001
Location: Omaha, NE
Posts: 962
I'm a little unclear about the nature of the sound. On the heading it says "ABS chatter" but in the body of the text you describe it as "grinding." I don't know what would likely cause a grinding noise. On the other hand, if you're talking about feeling brake pedal pulsations at low speed, esp. with wet rotors, from the activation of the ABS, you may just need to clean out your wheel sensors. Lots of posts on this so do a search and you'll see what you need to do.
'93 400E
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:42 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page