Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 11-11-2002, 03:53 PM
johnp123
Guest
 
Posts: n/a
ANY WAY TO JUST LOOK @ IT AND BE ABLE TO TELL IF ITS NOT WORKING RIGHT? or not/
Reply With Quote
  #17  
Old 11-12-2002, 12:06 PM
Chris17H
Guest
 
Posts: n/a
I don't know of a way just to look at it, maybe someone else does.
Reply With Quote
  #18  
Old 11-13-2002, 12:46 AM
Member
 
Join Date: Feb 2000
Location: seattle, wa
Posts: 87
one wat to tell is to look and see if the adjuster is all the way to the end of the reverse threaded rod.
paul
__________________
Paul Roberts
Mercedes Centrum Inc.
Bellevue,WA.
Reply With Quote
  #19  
Old 11-13-2002, 04:41 PM
Registered User
 
Join Date: Jul 2002
Location: NH
Posts: 47
just an idea- you said that you are pretty sure of the problem, but in my 1986 300E, i heard a similar screaming noise to what you described, but only at high speeds. i was told that the old mercedes' have poor speedo's, and can get noisy with age, the problem only worsening with the onset of cold weather. just a thought though...
__________________
Chase O.
86 300E 242k
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page