Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-10-2002, 09:58 PM
Registered User
 
Join Date: Aug 2002
Location: Atlanta Ga. area
Posts: 24
heater system valve -85 300CD

It's mighty cold in the old Benze...when I turn the heater control up to red "max", I get a puff of warm air, then cold...like nothing (much)is circulating in the heater core. How can I trouble-shoot the valve that opens/closes to allow the warm water to circulate?

My initial thought was to try a hammer, but I decided to check this group first.

__________________
...a man's gotta understand
his limitations...

83 300D 360 K (Big Blue)
85 300CD 250 K (Little Blue)
Reply With Quote
  #2  
Old 11-10-2002, 10:14 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
The mono valve is most likely the culprit. The repair kit is available from the fastlane.

CLICK HERE TO SEE IT!
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
  #3  
Old 11-10-2002, 10:23 PM
Registered User
 
Join Date: Aug 2002
Location: Atlanta Ga. area
Posts: 24
Benzmac

Thanks for the note...just looking at the pic of the replacement part, it appears that the valve can be dissasembled, the "stuck" core removed, and the replacement inserted...how much of a job is that? I'm fairly handly with tools.

It is worth a try to disassemble the current valve and just clean it up, possibly restoring function?




Mike
__________________
...a man's gotta understand
his limitations...

83 300D 360 K (Big Blue)
85 300CD 250 K (Little Blue)
Reply With Quote
  #4  
Old 11-20-2002, 12:18 AM
Registered User
 
Join Date: Aug 2002
Location: Atlanta Ga. area
Posts: 24
Benzmac
It's not the valve as far as I can tell. I disassembled the valve just to have a look at how it was put together and it appears to be in good condition. Just for fun I bypassed the valve with a piece of heater hose just to see if the heater would work. After reaching operating temp, it will givea puff of warm air that gradually cools to ambient temp...same as when the valve is hooked into the cooling loop. I am guessing now that the heater core is mostly blocked...any "best way" to clean one in while still in the car?
__________________
...a man's gotta understand
his limitations...

83 300D 360 K (Big Blue)
85 300CD 250 K (Little Blue)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:57 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page