Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-18-2002, 01:21 PM
Posts: n/a
'87 190E rotor problem

My '87 190E has fallen and I am not sure I can get it back up.

I traced the sudden problem to the distributor cap and rotor. Knowing I should have replaced them some time ago I bought new ones and put them in. No joy. A little further looking and I realized that the rotor was not being spun by the motor. Pulled the distributor and stuck my finger in to find the gear that drives the rotor is freewheeling.

What is the probable cause, damage, and cost?
Reply With Quote
Old 11-18-2002, 02:10 PM
it leaks, its german
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
Sounds like a rotor stand blew apart. Thats cheap. If the timing chain broke.... thats expensive.

Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
Reply With Quote
Old 11-19-2002, 09:44 PM
Posts: n/a
I think the timing chain drives a sprocket that drives a worm gear that drives the rotor. If chain breaks, worm gear will freewill. I think these are not interference engines... i.e. the valves wont get bent when the timing chain breaks.

Does the car not run at all?
How did it die? All the sudden?
How many miles are on it?
Was it making any special noises prior to it failing?

My 1986 190E with 98000 miles has motor noise and lack of power. I cant go over 60 mph.

Good luck.
Reply With Quote
Old 11-19-2002, 11:07 PM
Posts: n/a
Is it a 2.6 or 2.3?
Reply With Quote
Old 11-21-2002, 01:16 PM
Posts: n/a
It is a '87 190E 2.3, dosn't have any fire at the spark plugs so it dosn't run. Happened suddenly in my driveway thankfully. It has 197K on the broken odometer so I am going to guess 230K miles.

It seems to me that it must be the timing chain. I pulled the rotor stand out and could feel the horizontal drive shaft and gear (oil pump drive shaft?) freewheeling.

Drove fairly well up to the end. Some rough idle at times but only on idle, ran great.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:02 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page