Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-17-1999, 04:17 PM
NothiMB16
Guest
 
Posts: n/a
i hear that jump started the car can cause stalling and rough idle, sometimes hard starts and poor performance. well, after the jump started i noticed these things. the car starts ok, but at times having trouble maintaining idle. i have to depress the accelerator to give gas and the car will maintain running, but if i take the foot off, then the engin dies. if try to restart a few times, without giving gas, with luck it runs fine. i thought this is cause by a bad over voltage protection relay. checked it out, fuses is ok and put it back. if the fuses are fine, can the relay go bad? or might just need a tune up first, aprox 80k miles.
after messing around with the relay, the antilock light comes on and stays on. any idea? what went wrong? what can i do? thank you in advance for your expert advice.
noth
  #2  
Old 08-17-1999, 08:45 PM
Alain V.'s Avatar
Senior Member
 
Join Date: Aug 1999
Location: KS.
Posts: 459
I have seen bad overload protection relays with fuses that are still good. When you jump started the car if you caused a voltage spike it can kill the relay.
  #3  
Old 08-17-1999, 10:34 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Replace the relay. We should be able to send you one on the partshop.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
300SD hard cold start - glow plugs or compression? PC Dave Diesel Discussion 16 03-24-2004 01:01 AM
240d hard start madsen Diesel Discussion 5 10-03-2003 09:01 PM
Poor throttle response, hard start zorin Tech Help 0 02-16-2003 12:25 PM
M103 hard start, rough idle, hesitation SOLVED tryan Tech Help 9 02-12-2003 06:00 PM
Can anyone help me to analyze: Hard start 400E... carman850 Tech Help 5 11-27-2001 08:22 AM



All times are GMT -4. The time now is 02:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page