Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-22-2002, 02:16 PM
Registered User
 
Join Date: Nov 2002
Location: Tucson, AZ
Posts: 306
420 sel climate control

As a new owner of my first mercedes, I am slowly working my way through the typical problems. So far I have taken car of all except my climate control. After reading every archieved thread on this board (and mbzn) plus having a local shop check it out, I am still puzzeled.

Symptoms-----when heating I get warm air out the side vents and cool or cold air (depending whether or not I have A/C Selected) out the center and lower side vents. The flaps are not changing position regardless of heating or cooling but the heat does cut off if the temp set point is higher then inside temp at which point I will get cool air from the upper side vents. Defrost selection give warm air out the upper side vents and window vents. I think the center vent is still open but cann't remember and the wife has the car.

I took it to a shop this week and the mech said all six (?) vacuum valves are leaking vacuum and that sometime in the past they were bypassed. No other details.

Question-------doesn't it seem strange that all six valves would fail? If so, where is a good source for these valves. I can not find them in the online stores under the climate control section.

tks for your help
__________________
Litton
'90 420 SEL (sold)
'72 280 SEL 4.5
'98 ML320 (for sale)
'86 560SL
'05 Jeep Grand Cherokee Ltd (offroad in style)
'87 Chevy Blazer (AZ Pin Strips)

Last edited by Litton; 11-22-2002 at 03:08 PM.
Reply With Quote
  #2  
Old 11-22-2002, 03:26 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Not likely that they are all bad. The defrost defaults to "On" meaning if you ever aren't "On" then it holds. The center duct defaults "Off" so it must be holding since its working and not in the default position.

I checked the first number and fastlane had them. Here are the numbers to put into the "Search by part number": 000 800 57 75 main air flap (recirc), 000 800 58 75 main air flap, 000 800 43 75 Defrost, 126 800 14 75 legroom, 000 800 67 75 center duct, 000 800 40 75 air scoop (?).

If you can replace them then you can check them. Some are a b**** so identify those you feel are leaking then decide if you can get to them.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #3  
Old 11-22-2002, 04:42 PM
Registered User
 
Join Date: Nov 2002
Location: Tucson, AZ
Posts: 306
Flap Positions Clarified

Steve, thanks for the comments and part numbers. My wife just got back so I was able to take another look. It seems that in defrost, the center vent is open and the fan goes to high speed. In normal operation, it appears that the defrost vents are still open and I think the whole system is stuck in recirc.

What is the best way for a DIY to check for vacuum leaks on the valves?

tks again for all your help.
__________________
Litton
'90 420 SEL (sold)
'72 280 SEL 4.5
'98 ML320 (for sale)
'86 560SL
'05 Jeep Grand Cherokee Ltd (offroad in style)
'87 Chevy Blazer (AZ Pin Strips)
Reply With Quote
  #4  
Old 11-22-2002, 06:48 PM
Registered User
 
Join Date: Nov 2002
Location: Tucson, AZ
Posts: 306
Update

Just chatted with the shop and they said that all the valves are not really bad, but, while they have the dashboard off we might as well replace all of them. The quote was $800.00 parts and labor. Does this sound reasonable?
__________________
Litton
'90 420 SEL (sold)
'72 280 SEL 4.5
'98 ML320 (for sale)
'86 560SL
'05 Jeep Grand Cherokee Ltd (offroad in style)
'87 Chevy Blazer (AZ Pin Strips)
Reply With Quote
  #5  
Old 11-22-2002, 08:55 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Litton

I've been following this thread .... I would have them replace them. Considering you are already there and have the labor into it. I would say they are offering a fair deal.

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page