Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 08-21-1999, 06:26 AM
Posts: n/a
The lowbeam on my left headlight stopped working. After replacing the bulb, to no avail, I checked the fuses, and tested the current from the fuse box, which is fine. I discovered that there is no current running to the left low beam. My high beams are fine on both sides.

What component within the low beam circuit could cause the failure?

Thank you.

Old 08-21-1999, 08:17 AM
Jason Alexander
Posts: n/a
First check for any broken or dmaged wires to that side. Also check for any corrosion at the fuse panel. It's also possible that a problem exist in the dimmer switch for the high beam.

ASE Master Technician, Lead Technician for Deutsch American Inc. Over 6 years of Import experience-specializing in German Automobiles.

Old 08-21-1999, 09:29 AM
Posts: n/a
When you say dimmer switch for the high beam, are you talking about the low/high beam switch found on the steering column? How do I test it? I'd hate to replace it, and then find out that it isn't the problem (although I strongly suspect that it is).

Does Mercedes use fusible links?

Thank's for your response. I'll start by checking the wires.

[This message has been edited by Larry (edited 08-21-1999).]
Old 08-21-1999, 11:20 AM
Senior Member
Join Date: Apr 1999
Location: Walnut,CA,USA
Posts: 554
Have you check your exterior lamp faolure monitoring unit (inside your fuse box) you have to unscrew the fuse box cover to find it.

MB STARS Master Guild Technician,12 years MB tech
5 years independent shop owner
Old 08-22-1999, 10:14 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
The monitoring unit on the 300E could be faulty, but more often than not I have seen a fuse that is cracked so slightly that you can't see the crack. Start with replacement of the fuse!


Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
86 300E low beam headlight problem. immunity Tech Help 11 02-17-2005 09:40 PM
FS: 1987 300E low miles great cond. schumi Mercedes Cars For Sale 1 09-07-2004 04:19 PM
Headlight problem with "new" euros 97 300D psfred Diesel Discussion 0 09-06-2004 09:58 PM
Ford Taurus compressor; 300e evaporator failure; c230 AuctorEcclesiae Open Discussion 0 11-22-2003 03:53 PM
FS 300e w124 PARTS ON EBAY!!!!!!! 6cndmbz Mercedes Used Parts For Sale & Wanted 4 09-20-2003 12:14 PM

All times are GMT -4. The time now is 05:00 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page