Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-06-2002, 10:39 AM
Registered User
Join Date: Dec 2002
Posts: 31
Exclamation 91 Mercedes benz idle problem

I have a 91 300E mercedes benz 6 cylinder that has a rough idle ( more like a vibration) when in drive. It is not missing and passes state emissions tests with no problem. If the idle is raised (by stepping on the gas pedal slightly the vibration goes away. Any insight would be great.

Where can I find the horn relay, I have no horn, and can't seem yo find which relay is the horn relay.

Reply With Quote
Old 12-06-2002, 07:30 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Replace all 3 engine mounts...This will help!
Donnie Drummonds
Reply With Quote
Old 12-06-2002, 07:35 PM
Registered User
Join Date: Dec 2000
Posts: 368
Check your engine mounts.
Reply With Quote
Old 12-07-2002, 12:10 PM
pmizell's Avatar
Benz Zealot
Join Date: Jun 2001
Location: Houston, Texas
Posts: 838
Have you checked for blown horn fuse in fusebox?
'01 E430, Sport 72,000 mi
'98 C280, 126,500 mi
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:10 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page