Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-13-2002, 06:00 PM
Registered User
Join Date: Dec 2002
Location: Virginia Beach VA
Posts: 9
Cruise Control

Cruise control in my '85 300SD became intermittent. I took to my shop where they encouraged me to forget it. Seems their only success was with replacement of both Actuator and Amp. New Amp was too costly, but since problem was intermittent there was chance the improved new Actuator would fix. It did for three uses and quit.

I have secured and installed two used amps and neither work. when I plug the old amp back, it will work 1-3 times and quit.

My guys say everything else checks out, but have no way to check the amp. Any ideas on why it comes and goes will be appreciated.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:21 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page