Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-21-2002, 12:59 PM
Registered User
Join Date: Dec 2002
Location: Virginia Beach VA
Posts: 9
Cruise Control

My 1985 300SD is a great car. Recently painted, it looks as good as new. I plan to keep it and miss the cruise control that has failed over the past year.
I had my trusted shop test the system and install a new actuator. He did not encourage this repair saying he'd had no lasting success without the amp as well. Since it was intermittent, the feeling was the amp would have enough left to work with the improved actuator. It worked three times and quit.
I have installed two used amps and neither worked. Plugging the old amp back will get me one or two uses, then nothing. I am sometimes able to accelerate using the stalk, but it will not hold the speed.
Should I buy a rebuilt amp or is there another problem?
Reply With Quote
Old 12-21-2002, 03:53 PM
190dee's Avatar
Registered User
Join Date: Dec 2001
Location: Finland
Posts: 160

This is a very common fault. Use the search and type cruise control. You will find a link to a company that actually repairs these amps. Soldering joints in the amp are very likely to crack over time and...well you you know the result.

Good luck!
'87 MBenz 190E 2,3 8vlv
Reply With Quote
Old 12-21-2002, 05:35 PM
davidmash's Avatar
Join Date: Mar 2002
Location: Arlington, TX
Posts: 6,204
Check out these guys. They sold me a new Amp and actuator for my 190E 16V and it works like a charm. I have had it in sice summer and not a hic-cup yet.

Good Luck
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:34 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page