Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 09-16-1999, 10:01 PM
Posts: n/a
initially the tachometer worked intermittantly and when it stopped i used to press the air conditioning buttons and it used to start working.
now it is completely dead.
there is no amplifier under the hood.....only the pick up at the bell housing and the tachometer.
is the problem with the tach or the pick up
Old 09-17-1999, 07:41 AM
Posts: n/a
Look on the driver's side wheel well for a cylinder, about 1.5 inches in diameter and 2 inches high. Unscrew the top part from the car. You'll have a bell shaped part with a plug in it. Take the plug out of the bell shaped part (this can be hard...). Put a piece of foam or even a cigarette butt in the bell housing and put the plug back in. Screw it back on to the socket on the wheel well and try it.

Worked on mine and many others...


1982 300D - <A HREF="
" TARGET=_blank>

Old 09-17-1999, 09:38 AM
Posts: n/a
You're right...that model does not have a "tach amp". That system is routed through the
EGR cotrol box in the right side of the passenger footwell. It is also tied into the A/C compressor control relay circuit(if it has a "D-Klima" relay). Since fiddling with the A/C controls used to make it work...I'd look there first. Its rare to have a tachometer or the sensor fail. You can test the sensor with a Voltmeter.

ASE Master Tech
Mercedes Tech 19 Years
Old 09-17-1999, 11:43 PM
Larry Delor's Avatar
What, Me Worry?
Join Date: Jun 1999
Location: Sarasota, Fl.
Posts: 3,028
I had the same symptoms on my '83 300D. Turns out I also did not have any back-up lights. This led me to believe that perhaps a fuse was blown. It was not. But, upon closer inspection I could see what appeared to be an oily film on most fuses. So I got out my can of electrical cleaner, and Presto! All is well in tach-land. I hope this helps!

'83 300D-T
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1982 300SD turbo engine into a 1984 300D? cook Diesel Discussion 5 07-03-2004 01:25 PM
Fs 1984 300d gtt1 Mercedes Cars For Sale 10 05-16-2004 08:56 PM
No heat over 45MPH (1984 300D) ChrisBowen Diesel Discussion 10 02-20-2004 01:45 AM
squirrely front end 1984 300d mb1982 Diesel Discussion 2 12-02-2003 07:35 AM
Tachometer RPM 300D yel_low Diesel Discussion 1 03-12-2003 04:31 PM

All times are GMT -4. The time now is 07:21 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page