Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-25-2002, 11:38 PM
Registered User
 
Join Date: Aug 2000
Posts: 71
300SE issues..

My 300SE as of today, the windshield wipers don't work, the washer doesn't work, and the headlight wipers/washers don't work. the motor does not run. also, when I press the switch for rear defog, when I release it the light immediately turns off. I am going to muck around through the fusebox tomorrow and see if something is up there. Any guidance? also, my car has 167k miles, it has had head gasket replaced, cover replaced, timing chain replaced, and valve seals. Any other things I should look to fail or I should repair soon?
Thanks much,
Ben
__________________
currently just 1989 300SE 185k miles
Reply With Quote
  #2  
Old 12-26-2002, 01:36 AM
Bruce B's Avatar
Registered User
 
Join Date: Dec 2002
Location: east of Atlanta, north of Macon Ga
Posts: 185
Hiya Ben,

Yup, first thing I'd check would be the fuses, even if it looks good change it any way. All the stuff not working on mine when I bought it a month ago came to life with a fuse change (they appeared to be good ones BTW).
__________________
1991 300SE (my ride, 279,000 miles, looks almost new
1954 Cadillac (21 yo son's car, he bought when age 15)
1972 SeaBird 19 ft runabout (old but solid, slant six, Volvo sterndrive perfect condition, undergoing complete overhaul and refit)
1998 Toyota Rav4 (my sons daily driver when he is in the Continental US, PROUDLY serving in US Navy)
Reply With Quote
  #3  
Old 12-26-2002, 09:17 AM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
The W126 chassis has a COMBO relay that operates the rear defroster, wipers, & turn signals. Sounds like you are having problems related to that combo relay (back of fuse box).
MB part number 201-820-02-47.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #4  
Old 12-26-2002, 12:12 PM
Registered User
 
Join Date: Aug 2000
Posts: 71
My turn signals are working fine. could this still be an issue?
Ben
__________________
currently just 1989 300SE 185k miles
Reply With Quote
  #5  
Old 12-26-2002, 12:56 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Yes, the relay functions do not affect each other.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #6  
Old 12-26-2002, 01:37 PM
Registered User
 
Join Date: Aug 2000
Posts: 71
Thanks for all your help. I mucked around the fuse box this morning and it was a bad fuse. windows were also busted but room was working. It is all working now...however now I have an issue with a windshield washer fluid leak coming from the headlight washer system I believe. When I put fluid in, it all leaked out and there was a plastic hose that was seperated from this plastic connector where it splits into two hoses. I stuck it on and was going to clamp it on when a piece of the connector became stuck in the house. So now I need a new hose and connector. Can someone help me with part numbers or give me advice please?
Thanks much,
Ben
__________________
currently just 1989 300SE 185k miles
Reply With Quote
  #7  
Old 12-26-2002, 04:49 PM
Bruce B's Avatar
Registered User
 
Join Date: Dec 2002
Location: east of Atlanta, north of Macon Ga
Posts: 185
FWIW, to change fuses I have a pair of needle nose pliers wrapped with electrical tape, seems that you need some dainty 'lil fingers, which I don't happen to have, to get em out and back in
__________________
1991 300SE (my ride, 279,000 miles, looks almost new
1954 Cadillac (21 yo son's car, he bought when age 15)
1972 SeaBird 19 ft runabout (old but solid, slant six, Volvo sterndrive perfect condition, undergoing complete overhaul and refit)
1998 Toyota Rav4 (my sons daily driver when he is in the Continental US, PROUDLY serving in US Navy)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page