Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-12-2003, 10:42 PM
Registered User
Join Date: Feb 2002
Posts: 45
Exclamation Rear Power Windows In 84 190E

My power windows in my 84 190E don't work. I have no idea why. They were working in the summer but now they aren't. Like, the one on the right side works, but it comes down REALLY slow. When I go to put it up, it is soo slow to go up and seems so weak. The right side doesn't work at all but when you push the button, you hear a small clicking sound come from the window motor i guess. Does anyone know what's wrong or what I need to do? Thanks for all suggestions! - Ryan
Reply With Quote
Old 01-13-2003, 03:38 AM
sunil190e-1.8's Avatar
Registered User
Join Date: Jun 2002
Location: uk
Posts: 236
i would check the easy items first.

fuses -there is one for each power window-in the fuse box

nwxt i would check the indivdual switch that does not work-could be afaulty switch.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:15 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page