Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-01-1999, 07:38 AM
Registered User
 
Join Date: Sep 1999
Location: Atlanta, GA USA
Posts: 281
After fixing the Air conditioner this summer. The heater fails to generate any heat through the vents. Yes I have the Chrysler unit I'm pretty sure. Possibly a leak in one of the air hoses . Help I'm freezing.


Car-dude
  #2  
Old 10-01-1999, 12:50 PM
Aaron's Avatar
Moderator
 
Join Date: Aug 1999
Location: Cincinnati, Ohio
Posts: 1,935

Could either be vacuum problem or else heater core may be plugged. I had a similar problem of no heat a few years back on my 116 chassis 300SD, ended up replacing the heater core. It was an ugly job, but nothing I haven't seen before. Although the 116 is by far my favorite MB, I really hate that first generation climate control system. That's about the greatest benefit that the Euro spec versions had was the manual adjustment over our ACC system. Ok, hope this helps! I have been through 116 ACC systems many times, so if you need further assistance, please don't hesiate to write.


------------------
Rgds,
Aaron Greenberg
MB technician
'67 250SE Cabriolet
'77 450SL
'79 6.9
'79 6.9
'80 300SD
'81 240D
'85 380SE
'89 420SEL
'93 300E 2.8
  #3  
Old 10-01-1999, 12:58 PM
Registered User
 
Join Date: Sep 1999
Location: Atlanta, GA USA
Posts: 281
Unfornately I have the US spec AC unit, but lets say it was my heater core wouldn't it leak or something. Like the trusty American Cars.



------------------
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
New 300SD (1980) AC works now, no heat pjones300SD Diesel Discussion 1 09-06-2004 02:05 AM
FS: PS pump for 1980 450SE, SEL and others brandoncrone Mercedes Used Parts For Sale & Wanted 0 08-24-2003 09:39 PM
Interesting Post on AC from the Ritter/Easley Board ctaylor738 Tech Help 4 08-08-2003 07:36 PM
injector heat shields for a 300D - are they necessary? Kent300D Diesel Discussion 13 09-20-2002 12:18 AM
Parting out: 1980 450SE Euro brandoncrone Mercedes Used Parts For Sale & Wanted 0 08-15-2002 09:13 PM



All times are GMT -4. The time now is 08:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page