PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   No heat-1990 300SE (http://www.peachparts.com/shopforum/tech-help/5500-no-heat-1990-300se.html)

JoeVB 10-05-1999 09:36 PM

The A/C in my 1990 300SE has worked perectly all summer (I bought the car in June). Now I'm asking it for heat but what I get is luke warm air blowing onto the windshield (as if I had it in the defrost mode) and no air at all being directed to the floor. This is true even when I have the temp. wheel on full heat. Obviously the air is not being directed correctly for heat, but when the A/C is on, all the air comes from where it should, and none of it is directed at the windsheild. Where do I start looking? Thanks.

MB STARS 10-06-1999 01:01 AM

Have you read your owner's book, the book tells you how air condition & heating system
works.the center vent never open in heat mode
hope this help.

------------------
MB STARS Master Guild Technician,12 years MB tech
5 years independent shop owner

JoeVB 10-06-1999 09:23 AM

The vents are closed. It really acts as if it is in defrost mode no matter which buton I push except that the fan speed is changeable.
Thanks.

metricman 10-06-1999 09:00 PM

1990 300SE, that would be the W126 chassis.

Two seperate problems:

First, poor heat. Reguardless of where the air is blowing, if it is lukewarm when the temp. wheel is on full heat the first place to check is the mono valve (heater valve). It is located near the battery just in front of the windshield. There is a little two pin plug on top of it. 4 screws hold the top on it and there is a rubber diaphragm that probably has a hole in it. Its a 5 minute job if you don't drop the little screws down the firewall. Very common.. always the first place to look.
If it was not torn, and you don't have a thermostat problem it gets more complicated.

Second, as mentioned by someone else, pull out your owner's manual and verify the function of the air vents. You will not get any warm air out of the center vent in these older body styles. But in a heating mode, you should get air blowing from the side vents and the footwells flaps. If not, you may have a vacuum leak.

Good luck, let us know what you find....

------------------

Benzmac 10-06-1999 09:41 PM

We sell the mono valve insert in the partsshop.

JoeVB 10-07-1999 08:14 AM

Thannks for the replies. I will check the mono valve, but as I've stated, the real problem seems to be no air comming from the footwell flaps and lots of air comming from the windshield vents. And I'm not in the defrost mode.
Thanks again.
Joe


All times are GMT -4. The time now is 01:58 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website