Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-21-2003, 01:16 PM
Registered User
Join Date: Jan 2001
Location: Cedar Rapids, Iowa
Posts: 63
'89 420 SEL missing port

Just finishing up my short block replacement and came up with an extra vacuum line that I can't match to the engine. It's hard black plastic and the Mitchell diagram shows it coming off the driver's side of the venturi to a tee at the charcoal cannister on the left fender. It has been eaten off like it was rubbing on a pulley. The other end is not on the engine that I can find and the port in the venturi doesn't exist. Even got out my spare and looked underneath. Can anybody tell me where it hooks up?
'89 420 SEL "Moby Dick"
'30 Ford Coupe
'31 Ford Slant Windshield Town Sedan
'33 Ford Pickup
'34 Ford Pickup
'01 Honda Passport
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:53 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page