Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-27-2003, 05:04 PM
Registered User
 
Join Date: Dec 2002
Location: Virginia Beach VA
Posts: 9
Cruise Control

Cruise control in my '85 300SD became intermittent and quit. Against the advise of my main mechanic, he installed a new actuator and checked out the system. It worked twice and became intermittent again.
Not willing to spend $600 for a new Amplifier, I tried two used and neither worked. I sent mine to be rebuilt. I installed it and it worked twice and has quit.
The stalk switch is tight. My mechanic says everything he checked was O.K. (he could not check amp).
Any ideas on what is wrong before I take it back to the shop?
thanks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:36 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page