Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-27-2003, 11:17 PM
Michael Shane
Posts: n/a
Smoke on Start and Acceleration

Have a chance to buy a 1983 SD with 175,000 miles. Starts great but has blue smoke for awhile and and low rpms. Loss of power in lower range, but gets better in higher rpms, smoke lessens. Seems to miss a bit in lower rpms.
Reply With Quote
Old 01-28-2003, 05:13 AM
Registered User
Join Date: Jan 2003
Location: Epsom Downs, England
Posts: 152

Sounds like valve guide seals (at least).

If it's misfiring at low revs then performance will be down. Why it is misfiring could be almost anything.

Try to get a drive of another one to see if the lack of go at low revs is a fault with this articular car, or just a characteristic of the model.

If you go ahead with this, adjust your offer price to allow for some engine work. Wether the engine work is major or minor can't be established without some investigation that I guess the owner wouldn't want you doing

If the price isn't right to allow you to do some fixing, walk away, there's plenty more out there.............
Paul Gibbons
'93 320CE
'73 Jensen Interceptor (Resting)
Giant Full Sus Mountain Bike
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:42 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page