Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-29-2003, 08:27 PM
Registered User
 
Join Date: Apr 2001
Location: Doylestown, PA
Posts: 124
Question Missing Transmission Fluid

Hello all,

I have a new problem with our '88 190e. The tranny fluid seems to be disappearing. It has about 185k on it but the odd thing is that there is no trace of leaking fluid. It is a little wet underneath the tranny but there is never a puddle or so much as a drop of fluid under the car. It's going through a quart every 100 miles or so which is a pretty heavy leak I think. It shifts fine when the level is up. Anyone have any tips or tricks? Even suggestions?

Thanks

Kodiak
__________________
1988 190E 2.3 (178,000)
FastLane, PartsShop and this forum rule!!!
Reply With Quote
  #2  
Old 01-29-2003, 08:35 PM
yal's Avatar
yal yal is offline
Benz-smart
 
Join Date: Oct 1999
Location: New York, Long Island
Posts: 2,705
My guess is your fluid is burning off at the catalylic convertor. Mine is doing the same thing and I am taking it to my mechanic tomorrow to see if he can trace the leak. Do you notice the smell of ATF after driving for awhile?
Reply With Quote
  #3  
Old 01-29-2003, 08:47 PM
Registered User
 
Join Date: Apr 2001
Location: Doylestown, PA
Posts: 124
Thanks for the respons yal.
I assume you mean it is leaking and burning up when it hits the cat? I have not noticed any smell but I wouldn't rule it out. I also am hoping to take a look tomorrow. Let me know how you make out.

Kodiak
__________________
1988 190E 2.3 (178,000)
FastLane, PartsShop and this forum rule!!!
Reply With Quote
  #4  
Old 01-29-2003, 08:49 PM
yal's Avatar
yal yal is offline
Benz-smart
 
Join Date: Oct 1999
Location: New York, Long Island
Posts: 2,705
Quote:
Originally posted by Kodiak

I assume you mean it is leaking and burning up when it hits the cat?

Kodiak
Yes thats what I meant.
I'll let you know how it goes.
Reply With Quote
  #5  
Old 02-04-2003, 07:35 PM
yal's Avatar
yal yal is offline
Benz-smart
 
Join Date: Oct 1999
Location: New York, Long Island
Posts: 2,705
Kodiak it was the front tranny seal that was causing my leak.
Reply With Quote
  #6  
Old 02-05-2003, 04:49 PM
Registered User
 
Join Date: Apr 2001
Location: Doylestown, PA
Posts: 124
I dumped some tranny seal in and voila, it seems to have worked...for now anyway. I'm going to leave it alone for the time being. Thanks for all the input.
__________________
1988 190E 2.3 (178,000)
FastLane, PartsShop and this forum rule!!!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page