Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-30-2003, 09:30 PM
jack baker
Posts: n/a
Thumbs down no heat

new to this forum..need help to get to constant flow of in car heat throgh the vents....every once in a while the hot or warm air stops and minnesota cold air blasts out air vents....this may last for several miles or hours.....if anyone could give me direction on what maybe the problem sure would appreciate the help.. 1991 420 sel.. thanks train loads..jack
Reply With Quote
Old 01-30-2003, 10:25 PM
Registered User
Join Date: Apr 2001
Location: Joliet Illinois
Posts: 309
No Heat

No answer yet Jack...just sympathy. My '88 260e just started doing the same thing about a week ago. Even on max heat the center vents open up and blow cold air from outside. I tried pushing all the buttons and eventually the hot air will start again but I know something is going wrong. I suspect my pushbutton controller may be going bad.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:08 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page