Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-10-2003, 09:56 PM
pesuazo's Avatar
Registered User
 
Join Date: Oct 2002
Location: Near Raleigh, NC
Posts: 580
Unhappy Very Strange Engine Behavior

Everything was perfect this morning, car started and ran without any problems. Park at work come back out 9 hours later. Start the car, it idles really bad. Like 5 cylinders.
I give it gas, no reaction for 3-4 seconds then sort of catches and surges and inmediately lets go (some sort of popping sounds coming from engine compartment). It did it several times before it idled normally. Drove home 15 miles without problems (65 mph steady). I get to the first light, no problem. When starting to give gas same thing again, no response when given gas, then all of a sudden (popping sounds) surges and runs without problems. I get home and park it idles like crap again, in neutral, park, reverse, drive.
I give it gas it does not responds, it hesitates, shakes, pops and it revs up again normally and idles ok.
I go for a drive, in the beginning it hesitates,pops, almost dies, revs up tires screech and runs and idles like a champ.
Come back home idles OK, shut-off, start again and no problems.
Go out 2 hours later no problem.
What will tomorrow bring?
Done Very recently:
Oil and filter change every 2500 miles (religiously)
Done recently (within 6 months or 15K miles):
New OVP, New coil, sparks, distributor, rotor, air filter. Recently went from NY to Fl back to NY and now NC, ran fuel injector cleaner-techron.
Done not too recent (30K miles ago):
Wires, fuel filter

Any suggestions-advise-possible diagnosis?
__________________
1999 Porsche 996 Carrera Convertible
1994 420E - SOLD
1986 300E - SOLD, what a car
609 Certified
Reply With Quote
  #2  
Old 02-10-2003, 10:36 PM
Jackd
Guest
 
Posts: n/a
I would suspect water in gasoline, clogged fuel filter, fuel pump or fuel relay, ignition problem (distributor cap/rotor, coil)
Good luck
JackD
Reply With Quote
  #3  
Old 02-10-2003, 11:43 PM
Moderator
 
Join Date: Dec 2001
Location: Southern California, U.S.A.
Posts: 8,508
I would also suspect a defective mass air sensor.
__________________
Paul S.

2001 E430, Bourdeaux Red, Oyster interior.
79,200 miles.

1973 280SE 4.5, 170,000 miles. 568 Signal Red, Black MB Tex. "The Red Baron".
Reply With Quote
  #4  
Old 02-11-2003, 08:09 PM
pesuazo's Avatar
Registered User
 
Join Date: Oct 2002
Location: Near Raleigh, NC
Posts: 580
Update

It worked very well today, with one exception. When back from work (engine at normal operating temperature 87C), the car did not go back to normal idle (approx. 650-700 RPM in park or neutral). It sort of oscillated between 500-900 RPM for about 15 seconds before settling at normal. It did it several times, in intervals of about 3 minutes.
What should I look for?
__________________
1999 Porsche 996 Carrera Convertible
1994 420E - SOLD
1986 300E - SOLD, what a car
609 Certified
Reply With Quote
  #5  
Old 02-11-2003, 10:15 PM
Moderator
 
Join Date: Dec 2001
Location: Southern California, U.S.A.
Posts: 8,508
A fluctuating idle like that sounds like a faulty mass air sensor, or a vacum leak.
__________________
Paul S.

2001 E430, Bourdeaux Red, Oyster interior.
79,200 miles.

1973 280SE 4.5, 170,000 miles. 568 Signal Red, Black MB Tex. "The Red Baron".
Reply With Quote
  #6  
Old 02-12-2003, 12:02 PM
jhal's Avatar
Registered User
 
Join Date: Dec 2002
Location: Brooksville Fl
Posts: 226
Idle air bypass valve? If it is sticking closed and/or open, it can cause the problems you describe. They get clogged up and stick. Sometimes a good cleanining with carb cleaner is a good (though temporary) fix to see if it is the problem.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page