Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-21-2003, 01:08 PM
Registered User
 
Join Date: Aug 2002
Location: Milwaukee, WI
Posts: 126
300 SEL Transmission Downshift Trouble

It's a 1990 with around 185k miles. Fluid/filter hve about 20k miles over two years.

Wife reports that when highway cruising, if the accelerator is let up, transmission downshifts to third and will not go back up into fourth when accelerator is depressed. If the car is stopped, it will upshift properly again.

This problem started two days ago, and wife reported that it did not do it this morning. Commute to work is about 20 miles, so that's plenty time to get up to temp. Unfortunately, we couldn't swap cars today so I haven't had a chance to drive it myself.

Suggested places to start and things to look for?

Thanks.
Reply With Quote
  #2  
Old 02-21-2003, 04:33 PM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 19,751
Make sure the carpet isn't tangled with the kickdown switch behind the accelerator pedal.

Sixto
91 300SE
87 300SDL
83 300SD
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page