Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-25-2003, 09:59 PM
Registered User
Join Date: Jul 2001
Posts: 8
Wink 190 E Squeak

I have a squeak that sounds like it is coming from the rear independent suspension, do I need to replace the rear sub frame bushings MB # 201 351 28 42? What else would cause this, it is starting to drive me nuts! '88 190E 2.3

Reply With Quote
Old 02-25-2003, 10:06 PM
MTI's Avatar
MTI MTI is offline
Registered User
Join Date: Nov 2002
Location: Scottsdale, Arizona
Posts: 10,627
Rember that the 190E was the first Benz with a computer designed "multi-link" rear suspension, so there's all sorts of sources for "squeaks" other than the subframe, including springs, sway bar links and fasteners, shock mounts, etc. See if you can't duplicate it by bouncing the rear end while parked, then isolate the location. Or put it up on a lift or jackstands and have a look underneath.
Reply With Quote
Old 02-27-2003, 09:17 PM
Registered User
Join Date: May 2000
Posts: 376
Use the search function.

Sweaking from rear suspension????

Reply With Quote
Old 03-06-2003, 12:44 PM
Registered User
Join Date: Jun 2000
Location: Saugus, CA USA
Posts: 1,974
I had a squeek in mine from the back. It turned out to be a loose exhaust fitting.
5 speed '91 190E 2.6 320,000 mi. (new car, fast, smooth as silk six, couldn't find any more Peugeots)
5 speed '85 Peugeot 505 2.5l Turbo Diesel 266,000 mi. (old car, fast for a diesel, had 2 others)
5 speed '01 Jetta V6 (new wifes car, pretty quick)
5 speed '85 Peugeot 505 2.2l Turbo Gas 197,000 mi. (wifes car, faster, sadly gone just short of 200k )
5 speed '83 Yamaha 750 Maxim 14,000 mi. (fastest)
0 speed 4' x 8' 1800 lb Harbor Freight utility trailer (only as fast as what's pulling it)
Reply With Quote
Old 03-08-2003, 02:25 AM
Registered User
Join Date: Apr 2000
Posts: 412
It could be the shock absorbers. I replaced mine with KYB because someone recommended them and they were crap. They wore out after 35,000 miles and were leaking oil and rusted on the piston shaft and were sqeaking to a point where it was embarassing. I purchase BOGE shocks and they are excellent. Look at the shocks the rust on he shaft could be it.
1990 190E 2.6
1996 Grand Voyager 3.3
1985 Mustang GT 5.0 5 SPD
1982 Suzuki GS 750T
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:17 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page