Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-06-2003, 11:16 AM
Registered User
 
Join Date: Mar 2003
Location: HOMESTEAD,FL
Posts: 2
1986 300sdl Turbo

PLEASE HELP!!!
RUNS VERY ROUGH/DIESEL INJECTOR NOZZLES ARE NEW/PUMP TESTED OK/WHAT ELSE CAN BE WRONG? HELP,THANK YOU!

ZFCZEPHIR
Reply With Quote
  #2  
Old 03-06-2003, 03:02 PM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 19,754
Did the ELR connector at the back of the injection pump come off? Only affects idle.

Might need new delivery valve seals.

Check balance, check compression.

Is the upper radiator hose too stiff to pinch with your fingers when the engine's idling?

Is there pressure in the cooling system hours after you turn off the engine?

Sixto
91 300SE
87 300SDL
83 300SD
Reply With Quote
  #3  
Old 03-06-2003, 04:15 PM
yel_low
Guest
 
Posts: n/a
it is a 6 cyl? not the OLD 5 cyl...?


is the injection Timing Correct?


airbubbles in the fuel hose?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page