Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-07-2003, 06:29 PM
ZorroAMG's Avatar
Registered User
Join Date: Dec 2002
Location: Calgary, Canada
Posts: 131
Just a Great Big Thank you from a NEWBIE!

I was driving today in -30 celcius and my blower quit on me....I went to 2 service shops here, one dealer, one independent and neither wanted to help without a diagnostic charge which is normal i guess but in this case i was thinkng it was a fuse...they checked em and said it was the blower motor and about a grand to fix.....well I checked this wonderful Forum for blower motor and found a number of things to check...i checked said parts and was able to fix it in 74 seconds give or take 5, and for $0.00! I now have heat and can continue to enjoy my car. I know it is rather insignificant but just felt I should tell you all how great this forumm really is!! KEEP UP THE GOOD WORK!!!

Reply With Quote
Old 03-07-2003, 06:43 PM
Registered User
Join Date: Feb 2003
Location: Ontario, Canada
Posts: 3,160
Good to hear. Now you need yo tell us what was wrong with it.
2007 C 230 Sport.
Reply With Quote
Old 03-07-2003, 07:37 PM
MTI's Avatar
MTI MTI is offline
Registered User
Join Date: Nov 2002
Location: Scottsdale, Arizona
Posts: 10,627
And where to send the bill!
Reply With Quote
Old 03-07-2003, 09:10 PM
ZorroAMG's Avatar
Registered User
Join Date: Dec 2002
Location: Calgary, Canada
Posts: 131
hmmm....i know the invoice is here somewhere....

ummm...send the bill to my dealer
But seriously folks.....


(and please don't laugh when you hear this, after all the techs couldn't/wouldn't figure it out)

The external fuse to the blower motor was broken. The fuse was not listed on the fuse cover and i found the info here...went to the dealer, picked up a new one ( with a big grin and in a MATTER OF FACT kind of way told them I had fixed it...they felt rather dumb

Good luck to all and I hope I can be as valuable a member to all of you here as you have been to me.
Reply With Quote
Old 03-07-2003, 10:38 PM
Q Q is offline
Registered User
Join Date: Aug 2000
Posts: 839
Welcome to the club. For me, THOUSANDS SAVED using this forum.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 07:02 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page