Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-10-2003, 05:18 PM
skemper
Guest
 
Posts: n/a
loss of power on 300td

300TD 1985.

I have a problem with power loss and black smoke out of the tail pipe. After is move up to about 40mph the car will not accellerate. Once I hit 40 and give it all shes got the power immediatly is lost and black somke out the back. Some thing of a james bond trick.

I used to think it was the turbo but I have no idea.
Reply With Quote
  #2  
Old 03-10-2003, 05:48 PM
swede
Guest
 
Posts: n/a
sounds like a turbo to me
Reply With Quote
  #3  
Old 03-11-2003, 08:42 AM
it leaks, its german
 
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
There is a boost control switchover valve on the firewall kinda behind the oil filter housing, there is also a bango bolt (hollow bolt) in the back of the intake holding the supply line for the switchover valve, pull the bolt and see if the hole, bolt or line is clogged with carbon. Clear it and see if it boosts, if you have boost pressure to the switchover valve, bypass it. If that fixes the boost issue, it'll be wiring or some other eletrical problem, if there is no boost from the hole in the intake (just freewheel it to 3k with the bolt out while cleaning) then pop the elbow leading to the turbo and run it up one time, see if the pinwheel is spooling up.

99% of these are nothing more than bad switchover valves or clogged control lines.



Joe
__________________
Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
919-881-0364
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page