Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-18-2003, 08:30 PM
Registered User
 
Join Date: Mar 2003
Location: Carmel, CA
Posts: 301
Need some advice on my E420

It's doing some wierd electrical stuff.
Reply With Quote
  #2  
Old 03-18-2003, 08:31 PM
Registered User
 
Join Date: Jan 2002
Location: England
Posts: 1,841
Tell us precisely, in as much detail as you can, what its doing
__________________
190E's:
2.5-16v 1990 90,000m Astral Silver
2.0E 8v 1986 107,000m Black 2nd owner
http://www.maylane.demon.co.uk/190esmall.jpghttp://www.maylane.demon.co.uk/190esmall2.jpg
Reply With Quote
  #3  
Old 03-18-2003, 08:37 PM
Registered User
 
Join Date: Mar 2003
Location: Carmel, CA
Posts: 301
It started this morning when I started it. It made a wierd sound then my radio stopped working, antenna is stuck in the up position, my door locks don't work, and it's idleing rough. HELP!!!
Reply With Quote
  #4  
Old 03-19-2003, 09:21 PM
Registered User
 
Join Date: Mar 2003
Location: Carmel, CA
Posts: 301
Is there ANYONE that has had the same problem??
__________________
1973 280 - Sold
1980 300SD - Sold
1982 240D - Stolen
1988 300E - Sold
1989 260E - Sold
1989 560SEL
1994 E420 - Sold
1997 E420
2005 CL500
Reply With Quote
  #5  
Old 03-20-2003, 12:30 AM
Larry Delor's Avatar
What, Me Worry?
 
Join Date: Jun 1999
Location: Sarasota, Fl.
Posts: 3,076
Maybe yours is one of the cars that has the wire-harness issue. Try doing a search on it here.

-Larry
__________________
"...rationality of thought imposes a limit on a person's concept of his relation to the cosmos." -Nash

04/71 280SE 195k
09 Jetta TDI
Reply With Quote
  #6  
Old 03-20-2003, 07:09 PM
Registered User
 
Join Date: Jun 2001
Location: Omaha, NE
Posts: 962
More info, please!

--How many miles on the vehicle?

--What sort of weird sound did it make? For how long? Ever done that before?

--From WHERE did the weird sound seem to be coming? (e.g., under the hood, from the radio, from the trunk?

--Any recent work done on the vehicle?

--Have you checked the fuses? The radio/antenna problem sounds like it could be a blown fuse.

--Any other weird symptoms?

There IS an answer (or maybe several) to solve this; more specifics will help us logically help you figure it out.
__________________
Steve
'93 400E
Reply With Quote
  #7  
Old 03-20-2003, 09:14 PM
Registered User
 
Join Date: Mar 2003
Location: Carmel, CA
Posts: 301
Ok I'll try this again.
The car has 78000 miles on it.
It made a deep humming sound for about 2 seconds. It's never done it before. The sound came from under the hood. The only recent work was an oil change. All of the fuses are fine. Other wierd symptoms are as follows. 1. radio turns on but no sound. 2. Antenna does not go down any longer. 3. Door locks do not work. 4. When I turn on the rear seat passenger light from the switch on the dash the fasten seat belt light comes on. Hope this helps.
I called the local Benz dealer and wanna charge a fortune just to look at it. Help!!!

Thanks,
Allan
94' E420
__________________
1973 280 - Sold
1980 300SD - Sold
1982 240D - Stolen
1988 300E - Sold
1989 260E - Sold
1989 560SEL
1994 E420 - Sold
1997 E420
2005 CL500
Reply With Quote
  #8  
Old 03-20-2003, 09:26 PM
Registered User
 
Join Date: Jun 2001
Location: Omaha, NE
Posts: 962
What an odd combination of symptoms! Very difficult to reconcile, and what they have to do with the humming noise ... hmmm ...


When I hear about weird electrical problems that make no sense, what I've gleaned over the years from this and other MB lists:

1. Often OVP (overvoltage protection) relays are at fault. I'm pretty sure your car doesn't have an OVP (since it's basically the same as my car and I don't have one.)

2. Fuses, though looking good, can actually have hairline cracks and cause all sorts of weird, intermittant, nonsensical electrical glitches. One MB guru recommends replacing all ceramic fuses every ten years. You might want to go ahead and replace all the fuses even though it's a year early.(Get fuses from dealer -- I just did mine.)

3. The other thing that can cause weird electrical problems is a bad ground somewhere. Do you have the repair CDs? They have a listing of all the grounds. Even if you don't have it, you might want to check out the obvious grounds you see under the hood (e.g., near the right-side front shock tower) and in the trunk, near the antenna. You might get lucky and find that cleaning and tightening a bad ground connection could solve your problems.



If all else fails, and you can drive it up here, I have a GREAT independent mechanic who charges $55/hr and would track down your problem pretty quickly, I'd bet.
__________________
Steve
'93 400E
Reply With Quote
  #9  
Old 03-20-2003, 09:52 PM
Registered User
 
Join Date: Mar 2003
Location: Carmel, CA
Posts: 301
Where do I get the repair CD's????
__________________
1973 280 - Sold
1980 300SD - Sold
1982 240D - Stolen
1988 300E - Sold
1989 260E - Sold
1989 560SEL
1994 E420 - Sold
1997 E420
2005 CL500
Reply With Quote
  #10  
Old 03-21-2003, 09:37 AM
Registered User
 
Join Date: Jun 2001
Location: Omaha, NE
Posts: 962
RE: CDs, I THINK FastLane has 'em though I didn't see them when I searched on it. (FastLane is the sponsor of this list; see the button at the top of the screen to take you there. You can always call Phil who runs FastLane. He is EXTREMELY helpful and knows his inventory. Prices are generally about the best you'll find.)

If that fails, you can call 1-800-FOR MERC (the MB main phone line) and order from them (I think).
__________________
Steve
'93 400E
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page