Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 12-29-2000, 12:59 PM
longston's Avatar
Another View. . .
Join Date: Dec 2000
Location: Mark West, CA
Posts: 787
Another Good Point

Richard has addressed the other weak part of this assembly. The interior is hollow, and the only support for the connector pins are the three pairs of "clips", or "opposed locking fingers" as Richard calls them. However, there is one other weak area. So, when testing to see if the plate that holds these connector pins is loose, don't push very hard, or you are likely to dislodge one or more of them from the plate that they are fitted into that is held down by the three pairs of "clips", or "opposed locking fingers"(whew). These connector pins are simply glued into that plate, and not very well. Also, don't bother with the center, as that is just the latex potting compound, and pushing on that won't do you much good.
"We drive into the future using only our rearview mirror."
- Marshall McLuhan -

Scott Longston
Northern California Wine Country...
"Turbos whistle, grapes wine..."
Reply With Quote
Old 04-09-2003, 10:57 AM
rivermasternc's Avatar
J. Scott Moncrief
Join Date: Feb 2003
Location: Burnsville, NC
Posts: 144
OK. After spending about 3 hours of quality time with my Xacto set and the TDC amplifier, I have removed enough if the silicon to see that I do not have any broken or weak solder joints on the printed circuit board. I'm now thinking one of the electrical components. Based on the clock issue, my first thought is the FRAKO capacitor. I would welcome any other thoughts at this point.

The capacitor identification on the top is weak, but appears to be marked "100/16 FRAKO T2." The only number I am uncertain of here is the 100 microfarad rating, as a large portion of the number is missing. Can someone confirm this to be correct? The clock capacitor, rated 100/16, was labeled "100/16 FRAKO P8."

I have posted a couple pictures of the TDC amp innards for those who are interested. They are at:

1986 300SDL 202 Kmi
1989 560SL 105Kmi
1998 E320S4 (4-matic wagon) 140 Kmi
2000 F250SD 7.3l Powerstroke TurboDiesel 103 Kmi
1965 VW Beetle Deluxe 115 Kmi
2002 RC VW New Beetle
Previous MB:
1983 240D Euro Manual 144 Kmi
1986 190D 2.5 100 Kmi
1991 300D 2.5 Turbo 91 Kmi
1983 300SD 495 Kmi
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
##!! tach is doing it to me again. admanles Diesel Discussion 4 01-14-2005 05:53 PM
Tach Amp Question MB_SOOT Diesel Discussion 1 04-03-2003 07:23 AM
86 190E 2.3 - Tach, clock affected by fastening seat belt DieselGuy Tech Help 5 01-22-2003 01:51 AM
New 300 TD Tach Fix Andrew Fekete Diesel Discussion 10 04-15-2002 02:47 PM
How to get a tach ATLD Diesel Discussion 7 10-19-2001 06:20 PM

All times are GMT -4. The time now is 03:31 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page