Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-31-2003, 08:07 PM
Registered User
Join Date: Jan 2003
Location: MA
Posts: 114
Air condition 126

I have a 87 560 SEL....the A/C is blowing warm air. The compressor is working, but the hoses/lines are warm and you can see fluid/freonb traveling through the little window. The system has pressure too.

In most cars the problem would just be adding freon. Not sure if MBZ is different. Any ideas?
Reply With Quote
Old 04-01-2003, 07:52 AM
Posts: n/a
Are you seeing bubbles or liquid flowing through the sight glass?
If it is bubbles, you are probably low on refrigerant.

To diagnose properly, you REALLY need to hook up manifold gauges.

BTW, in principle, this a/c is no different than any other.

Good luck,
Reply With Quote
Old 04-01-2003, 09:27 AM
jhal's Avatar
Registered User
Join Date: Dec 2002
Location: Brooksville Fl
Posts: 226
Sounds like a bad expansion valve. Hard to tell without manifold gauge readings though.........Otherwise just an educated guess
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:41 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page