Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-06-2003, 08:26 PM
jack300
Guest
 
Posts: n/a
1990 300 sl hard starting

hard starting when car parked for one hour or longer(cold temp or warm temp),suspect fuel problem?how many fuel pumps?do they have ck valves?an accumulator?ovp relay?how do i ck...(coolant temp sensor and ignition components replaced),with tuneup.any help would be appreciated..thank you....
Reply With Quote
  #2  
Old 04-06-2003, 09:12 PM
pmizell's Avatar
Benz Zealot
 
Join Date: Jun 2001
Location: Houston, Texas
Posts: 838
Your 129 has 2 fuel pumps with check valves along with a fuel accumulator. The setup is located just forward of the rear wheel, passenger side underbody, under a black protective cover.

You can test to see if both pumps are operating by pulling the MAS relay and checking amp draw between big pins 1 and 2. Proper specs for 2 pumps is 6 to 7.5 amps.

Not sure if the early 3.0 104 engine has an OVP or not, but I suspect it does. Most likely located behind battery on passenger side.

Another suspect could be the fuel pressure regulator or old fuel filter.

GL
__________________
-Paul-
'01 E430, Sport 72,000 mi
'98 C280, 126,500 mi
Reply With Quote
  #3  
Old 04-08-2003, 01:24 PM
jack300
Guest
 
Posts: n/a
hard starting

what is an mas relay?
can i check the check valves and accumulator or would i just be better off replacing them?
how about the ovp relay,how would that prevent quick and normal starts?
thank you...
Reply With Quote
  #4  
Old 04-13-2003, 05:00 PM
Registered User
 
Join Date: May 2001
Location: Las Vegas, Atlanta
Posts: 669
MAS relay

M.B. Doc explained it to me here.

Last edited by bobterry99; 04-13-2003 at 10:07 PM.
Reply With Quote
  #5  
Old 04-13-2003, 06:50 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
The MAS is a larger OVP. It is just a power supply relay with spike protection. Sort of like a UPS for your PC.

The answer to your basic question depends on the natuer of your problem. If you have a problem cold the accumulator is not involved. If your problem is hot restart it could be. A hot restart problem would occur between 15minutes and an hour after stopping (with hot motor). The problem in these instances is a vapor locking condition due to fuel boiling when it isn't under pressure.

The fuel pressure builds almost instantly so the pressure doesn't have to last any longer than that which is necessary to increase the boiling point during the hottest period.

If on the other hand your problem is cold it is less likely to be fuel delivery related as fuel pumps that eventually work (at 6+amps each), work best when cold. More likely in this event is the lack of fuel enrichment (if this problem is fuel related and not ignition) for cold starting and cold running. This is accomplished by the EHA current being higher when cold. In cars with OVPs the way they affect cold starting is by shutting down the KE controller thus there is no enrichment at all.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #6  
Old 04-13-2003, 08:28 PM
pmizell's Avatar
Benz Zealot
 
Join Date: Jun 2001
Location: Houston, Texas
Posts: 838
I just learned that the 300SL ('90-'93) has a 103 engine (103.984) with an OVP as well.

GL
__________________
-Paul-
'01 E430, Sport 72,000 mi
'98 C280, 126,500 mi
Reply With Quote
  #7  
Old 05-05-2003, 09:18 PM
jack300
Guest
 
Posts: n/a
Thumbs down hard starting

i replaced the fuel pump check valves and the accumulator (which was leaking)..NO HELP..the car will not start on the first attempt..either overnight or if it has been shutdown 30 minutes or longer,second attempt,chugs a little then spools up and is fine.it runs good..can it be an ignition coil?fuel regulator?how can i check.i hate to throw parts at a problem.ANY HELP WOULD BE APPRECIATED...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page