Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-07-2003, 01:41 PM
Registered User
Join Date: Mar 2003
Posts: 7
Angry E320 Transmission

Lately, under fairly heavy acceleration, my 99 E320 drops into "neutral". I have to steer to the side of the road and shift into "park" and then back into "drive" to resume driving. Any idea what is happening ? Thanks.
Reply With Quote
Old 04-07-2003, 07:04 PM
Posts: n/a
Is it a 4Matic? Need more information.
Reply With Quote
Old 04-07-2003, 09:33 PM
DR.DIESEL's Avatar
Senior Member
Join Date: Mar 2003
Location: Puget Sound, Washington St.
Posts: 522
It is going into limp mode. There is most likely a fault
with the transmission electronics. You will need to have the
diagnostic trouble codes pulled from the control module
for diagnosis.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 07:48 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page