Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-10-2003, 09:39 PM
Registered User
Join Date: Oct 2001
Location: Western Mass.
Posts: 324
Brake failure

My 95 E3oo has intermitant brake failure. The pedal will go hard and no stopping power, then everything is OK. Sometimes on start up it will be hard then after driving a short ditance its OK again. Sometimes on the interstate it will happen on the off ramp.
Whats happening?

03 C240 4matic wagon
95 300E 234,000
7 prior 240;s 5 still going
81 300sd gone
65 230sl gone
49 Studebaker Champion
90BMW convert.167,000
60 Dodge D-100
Reply With Quote
Old 04-10-2003, 10:23 PM
I told you so!
Join Date: Jun 2002
Location: Motor City, MI
Posts: 2,741
It sounds like you're having intermittent problems with the vacuum brake booster system. Check the vacuum lines going to the brake booster.
95 E320 Cabriolet, 131K
Reply With Quote
Old 04-11-2003, 01:56 PM
sixto's Avatar
smoke gets in your eyes
Join Date: Jun 2000
Location: SF Bay Area
Posts: 18,745
Is that a 95 E300 or E320? If it's an E300 Diesel then it might be a fault in the vacuum pump.

91 300SE
87 300SDL
83 300SD
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 01:37 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page