Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-11-2003, 03:37 PM
Registered User
 
Join Date: Nov 2002
Location: florida
Posts: 83
Question wiper speed???

hello to all
on my 92 190e 2.6 i can't tell the diffrence on wiper speed 2 from speed 3 has anyone else notice this???
Reply With Quote
  #2  
Old 04-11-2003, 09:13 PM
haasman's Avatar
Registered User
 
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,097
Sounds like at least the wiper shaft could use lube.

There are many posts on this site regarding that. Try using the search feature, above right and use the key words: wiper lube

Keep us posted,

Haasman
__________________
'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
  #3  
Old 04-11-2003, 09:33 PM
Registered User
 
Join Date: Nov 2002
Location: florida
Posts: 83
no i just replace it with a new one
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page