Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-11-2003, 07:33 PM
mike690003's Avatar
Registered User
Join Date: Apr 2003
Location: Miami,FL
Posts: 807
Question Help me please I pulled my economy hose!!!

Hello, Board. I have a 1987 300E and I am in a serious crappy situation, I was doing my white Faced gauges that I bought from ebay, while I was pulling the cluster I mistakenly pulled out the Vacuum hose for my economy gauge wayy down past the cluster(probably from the beginning connection). The trouble is, that I dont know where that connection is. Someone please help me.
Reply With Quote
Old 04-11-2003, 07:59 PM
Registered User
Join Date: Apr 1999
Posts: 2,632
I believe it goes through a firewall grommet and to a check valve on the otherside of the firewall above the brake booster.

:-) neil
1988 360TE AMG
1993 500E
Reply With Quote
Old 04-12-2003, 07:48 PM
mike690003's Avatar
Registered User
Join Date: Apr 2003
Location: Miami,FL
Posts: 807
Thanks a lot, I looked under my hood and there it was. You saved me a lot of time and headache.

Thanks again
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 03:14 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page