Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 04-23-2003, 07:59 AM
Registered User
Join Date: Jun 2002
Posts: 22
300se Oil Level Light

My '90 300se doesn't do the following:

The headlight warning buzzer doesn't sound when the key is removed with the lights on and the low oil level light does not come on.( It needs valve seals and I jus haven't gotten there yet)

Anyone able to shed some light on the subject?

Regards and thanks... Paul G
Reply With Quote
Old 04-23-2003, 08:16 AM
Posts: n/a

Did the buzzer ever work? I know people that have disconnected the buzzer because it annoyed them. its located under the steering wheel compartment. First i'd check my fuses. I've heard that they go bad sometimes. Good luck. On the light subject most likely the bulb was removed, I've removed couple myself. its just annoying( i removed the srs). I wouldn't remove an important bulb like the oil one unless i knew there was a problem and put the car for sale.
Reply With Quote
Old 04-24-2003, 08:48 AM
Registered User
Join Date: Jun 2002
Posts: 22
Both the buzzer and light worked at one time. Fuses are all OK.

I'm assuming a realy to be the problem, and am looking for the right one?
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:44 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page