Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-14-2000, 11:27 PM
TomM
Guest
 
Posts: n/a
heater blower moter does not work. it works when applying 12 volts to motor. owner installed another switch, stiil not working...where is relay and/or fuse located?

second problem is that it runs way too rich; has three gas fouled spark plugs also. anyone have specs for MAP sensor? contact points for injectors inside distributor are dry.. any other leads appreciated..thanks in advance.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Return of idle problems - '91 190E 2.3 sbourg Tech Help 11 05-19-2003 11:25 AM
1980 450 SL Trunk Problems tomward SL Forum 7 04-22-2003 12:45 PM
76 450 slc idle problems shinjen Tech Help 4 09-16-2002 04:40 PM
450 SEL engine to a 450 SLC (79s), Problems? Leewolf SL Forum 0 03-05-2002 12:55 AM
1986 300E - 3n ew problems after service olivo880 Tech Help 3 10-31-2001 12:18 AM



All times are GMT -4. The time now is 06:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page