Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-14-2000, 10:27 PM
Posts: n/a
heater blower moter does not work. it works when applying 12 volts to motor. owner installed another switch, stiil not working...where is relay and/or fuse located?

second problem is that it runs way too rich; has three gas fouled spark plugs also. anyone have specs for MAP sensor? contact points for injectors inside distributor are dry.. any other leads appreciated..thanks in advance.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Return of idle problems - '91 190E 2.3 sbourg Tech Help 11 05-19-2003 10:25 AM
1980 450 SL Trunk Problems tomward SL Forum 7 04-22-2003 11:45 AM
76 450 slc idle problems shinjen Tech Help 4 09-16-2002 03:40 PM
450 SEL engine to a 450 SLC (79s), Problems? Leewolf SL Forum 0 03-04-2002 11:55 PM
1986 300E - 3n ew problems after service olivo880 Tech Help 3 10-30-2001 11:18 PM

All times are GMT -4. The time now is 08:38 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page